1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Brakes on

Discussion in 'Bay Tech Clinic' started by islandman, Nov 14, 2018.

  1. islandman

    islandman Member

    Messages:
    43
    Location:
    brisbane
    hi guys my bus was sitting for quite some time I am just trying to get her moving again issue is it rolls backwards fine but drive forwards and it is like the brakes are on! I have changed front pads flushed and bled the brakes they feel good just drives like brakes are on can any one shed some light as to where I should start to investigate ? 75 bay window front disc rear drums
     
  2. cbus

    cbus Well-Known Member

    Messages:
    10,921
    Location:
    sunshine coast
    Jack up each wheel in turn and attempt to turn wheel.
    Might isolate a particular wheel?
     
    Syncro27 likes this.
  3. Wayne murray

    Wayne murray Well-Known Member

    Messages:
    2,073
    Location:
    Seven hills
    Have you got your rear brakes adjusted correctly as if you haven't backed them off enough after adjustment they can be still slightly on. After you have driven the car if the brakes feel very hot to touch good chance they are still on.
    As mentioned above comments x two it gives you an idea of which wheel it might be.
     
  4. David H

    David H Well-Known Member

    Messages:
    3,555
    Location:
    newcastle
    As abovex3. Start with rear wheels. Sounds like leading edge of rear shoes biting. If above check shows rear is the problem, do as Wayne suggests. If that doesn't change it pull the drums off & check the rear brake shoes & where they're wearing (love English sometimes;)).
    Cheers
     
  5. grumble

    grumble Active Member

    Messages:
    930
    Location:
    Taree
    Possibly a seized piston in the rear wheel cylinder or blocked hose.
     
  6. Pisces

    Pisces New Member

    Messages:
    25
    Location:
    Brisbane
    Try staring it in first gear
     

Share This Page