1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Broken Odometer

Discussion in 'T3 & T4 Tech Help Clinic' started by hdj80, Jun 12, 2017.

  1. hdj80

    hdj80 Member

    Messages:
    99
    Location:
    Canberra
    My Odometer stopped working on my 1990 Syncro, Speedo still works but odometer doesn't. I am not after a upgrade as atm ok with what I had.
    Will any T3 Speedo/odometer work with my Syncro.? and if anyone happens to have a good one for sale I'll be happy to take it off your hands..
    Thanks
    Peter
     
  2. Syncro27

    Syncro27 Well-Known Member

    Messages:
    6,651
    Location:
    Terrigal, NSW Central Coast
    Hi Peter,

    You will need a syncro speedo with 1000 labelled near the base of the screen. 2wd vans all had 500.

    They are like rocking horse 5hit.

    Best of luck finding one.

    USA ones are labelled 1600 for syncros so you may have some luck off the Samba.

    Cheers
     
    Last edited by a moderator: Jun 12, 2017
  3. cbus

    cbus Well-Known Member

    Messages:
    13,570
    Location:
    sunshine coast
    Check that the shaft for trip meter hasn't slipped out of position.
    There's a fix if that's the problem.
    Check with Dapom
    That's if they are constructed same as 2wd in that area.
     
  4. Grantus

    Grantus Well-Known Member

    Messages:
    18,846
    Location:
    Southern ACT
    Keep in mind, if you find a "1600" one, it will be in Miles Per Hour. ;)
     
  5. Syncro27

    Syncro27 Well-Known Member

    Messages:
    6,651
    Location:
    Terrigal, NSW Central Coast
    I agree but they usually also have Km/hr in small letters beside the M/hr numbers.
     
  6. Dapom

    Dapom Well-Known Member

    Messages:
    805
    Location:
    Brisbane
    hdj80 and cbus like this.
  7. Mellow Yellow 74

    Mellow Yellow 74 Active Member

    Messages:
    847
    Location:
    Sydney
    Not sure if this is your issue, but often the odometer stop working because the main shaft moves out so the gear disengages. I found a bracket online that someone had designed to be 3D printed in order to fix this: https://www.thingiverse.com/thing:2104416 I had one made up and it turned out good, but it didn't fit my 85 speedo. If this will fix your odometer, I am happy to sell it to you for $20.
     
    hdj80 and Luckyphil like this.
  8. Luckyphil

    Luckyphil Well-Known Member

    Messages:
    7,079
    Location:
    Gosford
    If no one else wants this I will buy it. PM me postage & payment details.
     
  9. Dapom

    Dapom Well-Known Member

    Messages:
    805
    Location:
    Brisbane
    That's exactly what I had printed...you got a better deal on the printing than me!! Lol
     
  10. Beau

    Beau Member

    Messages:
    96
    Location:
    Sunshine Coast, QLD
    For any printing needs, I'm happy to print stuff for fellow VW enthusiast for the material cost :)

    Cheers
    Beau
     
    Dapom, cbus and Grantus like this.
  11. Dapom

    Dapom Well-Known Member

    Messages:
    805
    Location:
    Brisbane
    Hey all :) the bracket doesn't fit my early aircooled speedo. I don't know which year they changed but mine is a cast alloy body and the bracket works with the later plastic body. The alloy one doesn't physically have the posts that the fix bracket clamps to :(
    However....turns out my earlier fix was working and stopping the shaft sliding out....the issue was the cog being split. I've fixed that now too :)
    Long and short of it...I've got another bracket up for sale. Cost to me was $25 and postage is about $7 so $32 delivered. Let me know if anyone's interested :)
     

Share This Page