Found in rocker cover?

Discussion in 'Engine & Transmission' started by Midlifecrisis, Dec 29, 2017.

  1. Midlifecrisis

    Midlifecrisis Member

    Messages:
    40
    Location:
    WA
    Hello all,

    Could anyone please help? Today I adjusted my tappets and when I removed one of the rocker covers I found these parts of a plastic ring (seal?) inside it. The ring is hard plastic so doesn't look like it was ever a rubber seal. It is about 12mm in diameter and 2.5 mm thick.
    I can only imaging it was a seal of some sort in the push rod tubes.
    Could anyone tell me what it actually is? And what is the dangers of running the car without it being replaced immediately?

    Thanks in advance
     

    Attached Files:

  2. Barry

    Barry Well-Known Member

    Messages:
    2,449
    Location:
    Abbotsford NSW
    close - its a valve seal

    No biggie.
     
    rstucke likes this.
  3. rstucke

    rstucke Well-Known Member

    Messages:
    567
    Location:
    Wamberal NSW AUS
    Do you have AMC heads?
    When I bought mine and stripped them down I found something similar pushed on the inlet valves under the valve keeper
    I think they were some stupid idea for a seal that wouldn't work in a pink fit.
    A bit of manual research showed they were discontinued on later bays (not sure about splitties) so they were on genuine heads as well.
    I think what you have is a rubber seal that has been carbonized and broken apart.
    If so you'll end up with more down the track
    Pull the screen next oil change, you might find some there as well
    If I'm right you don't need to worry just pick them out as you find them.


    Barry's quicker at getting to the point
     
    Last edited: Dec 29, 2017
    David H and grumble like this.
  4. Barry

    Barry Well-Known Member

    Messages:
    2,449
    Location:
    Abbotsford NSW
    ha hah!

    never was one for detail
     
    David H likes this.
  5. Midlifecrisis

    Midlifecrisis Member

    Messages:
    40
    Location:
    WA
    Thanks for the replies.
    I will be changing the Oil and filter and cleaning the Oil screen shortly so I'll report back what I find in the Oil.
    Cheers
     
  6. cbus

    cbus Well-Known Member

    Messages:
    10,735
    Location:
    sunshine coast
    Also had same in a couple of engines.
    Bits kept turning up over a few oil changes without causing any issues.
     
  7. KahunaKombi

    KahunaKombi Super Moderator Staff Member

    Messages:
    18,153
    Location:
    Bracken Ridge, Qld
    Better to give the Readers Digest version over the War & Peace one :eek: .... facts not fluff ;)
     
  8. KahunaKombi

    KahunaKombi Super Moderator Staff Member

    Messages:
    18,153
    Location:
    Bracken Ridge, Qld
    Oil Strainer doing it's job :rolleyes:
     
  9. Midlifecrisis

    Midlifecrisis Member

    Messages:
    40
    Location:
    WA
    So today I completed the Oil and filter change and I didnt find any more hard plastic ring parts in the Oil or strainer.
    My 2 litre engine does have a separate oil filter so there may have been parts caught in this but I don't think so.
    It just seems that there was the one hard plastic ring (in parts) that was in my Oil.
     
  10. KahunaKombi

    KahunaKombi Super Moderator Staff Member

    Messages:
    18,153
    Location:
    Bracken Ridge, Qld
    Good result ;)
     

Share This Page