1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuel injection

Discussion in 'Fuel System & Electrics' started by tomar, Sep 1, 2018.

  1. cbus

    cbus Well-Known Member

    Messages:
    11,753
    Location:
    sunshine coast
    I would be betting on Chris' AFM check at mo as a possible.
    He has been through this system fairly comprehensively :D
     
  2. Dapom

    Dapom Well-Known Member

    Messages:
    676
    Location:
    Brisbane
    Great info :) on a side note....the ballast resistors are notorious for the cables to break where they are crimped onto the unit. If anyone needs a quick and easy fix for this give me a shout ;)
     
  3. Dapom

    Dapom Well-Known Member

    Messages:
    676
    Location:
    Brisbane
    My opinion is that that has to be checked properly before starting to play parts darts. if the afm is the problem then it’s fixed in 10mins. Ignition switch would be my next check if that is all good.
    ‘Fairly comprehensively ‘ bahaha I think that might be the understatement of the year lol
     
  4. cbus

    cbus Well-Known Member

    Messages:
    11,753
    Location:
    sunshine coast
    Totally agree.
    Don't go chasing rainbow utill the basics are checked.
    Follow supply of power.
    Process of elimination.
     
    Dapom likes this.
  5. Mr Beckstar

    Mr Beckstar Well-Known Member

    Messages:
    1,017
    Location:
    Bateau Bay, NSW
    Harry is 5/76. Here’s a pic of the left side of the firewall. Before the engine and carburetor rebuild :oops:

    DB0408BA-721F-430D-8266-F071DFEDF656.jpeg
     
    David H likes this.
  6. tomar

    tomar Member

    Messages:
    170
    Location:
    Burpengary
    Finally tracked it down, it was an either or, a faulty ignition switch or a bad connection at the ignition switch. Replaced the switch and started no problem .
     
  7. bern

    bern Well-Known Member

    Messages:
    1,031
    Location:
    Fernvale, Qld
    so you replaced just the bottom white pin plug unit tomar??
    I have a bus where the key return spring is not returning ...is this the same pin plug I can repl if this is so?
     

Share This Page