1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuel problem or something else????

Discussion in 'Fuel System & Electrics' started by auschook, Feb 2, 2015.

  1. auschook

    auschook Member

    Messages:
    129
    Location:
    Yeppoon Q'ld
    Hi fellow kombi worshippers. I am having more dramas with my beloved Frootloop and was hoping some of you switched on guys might be able to shed some light for me. I have a 76 2 litre fuel injected manual kombi. It has been doing a bit of backfiring and it seems to be running too rich. It takes a few starts to get her going and it seems to be stalling whenever I slow down to turn a corner or stop at lights. Friends have commented it has a strong petrol like smell also. The car usually runs really good so was hoping someone might be able to help. Cheers guys, any advice much lay appreciated
     
  2. Mellow Yellow 74

    Mellow Yellow 74 Active Member

    Messages:
    847
    Location:
    Sydney
    If your timing is too advanced it will stall when you come back to idle so this is worth checking, or the running rich and petrol smell could be a leaky injector.
     
  3. BrianK

    BrianK Well-Known Member

    Messages:
    7,746
    Location:
    Port Kennedy WA
    You might wish to check all your vacuum hoses
     
  4. mrsdawnrazor

    mrsdawnrazor Member

    Messages:
    47
    Location:
    Brisbane
    Sounds like timing to me
     
  5. gazman

    gazman Well-Known Member

    Messages:
    1,864
    Location:
    Perth WA
    +1
     

Share This Page