1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Motor not started for 6mths ,

Discussion in 'Engine & Transmission' started by RalphO, Dec 12, 2012.

  1. RalphO

    RalphO New Member

    Messages:
    7
    Location:
    Sunshine Coast QLD
    Hi , new to the forum , picked up a 76 camper it has a 2L with injection , it hasnt been started for about 6mths but the guy i got it off reckons , Just throw a battery at it and it will fire up, so should i drain the fuel and change filters , drain the oil as well ( which oil to replace ?? ) and change the plugs ( which ones to replace with ) just want to be able to move it in and out of the yard while i get it roadworthy ,
    cheers Ralph
     
  2. Alpal

    Alpal Moderator Staff Member

    Messages:
    9,037
    Location:
    Melbourne Bend of Islands
    Fuel may be a bit suss. Unleaded has a limited shelf life. Otherwise just make it go. Oil and filters etc. when you are ready to travel.
    Plenty of discussion on this site re oils. try a search.
    Enjoy the ride!
     
  3. RalphO

    RalphO New Member

    Messages:
    7
    Location:
    Sunshine Coast QLD
    Well after waiting for the PO to send me the keys for the fuel cap to no avail , couldnt wait any longer , so carefully mangeled the cap to get it off , 10 ltrs of 95 in the tank , new battery , hit the key , you bloody beauty the old girl fired straight up and settled down to a nice rummpy idle , gotta be happy with that !!!
    cheers Ralph
     
  4. cbus

    cbus Well-Known Member

    Messages:
    13,570
    Location:
    sunshine coast
    Pretty lucky. they can be a bitch.

    would warm it up and do an oil change just for the hell of it
     
  5. GrandWarrior

    GrandWarrior New Member

    Messages:
    15
    Location:
    Adelaide
    Wheres the pics ?
     

Share This Page