1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No top end power through gears

Discussion in 'T3 & T4 Tech Help Clinic' started by UK Skippy, Oct 19, 2019.

  1. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Original tank I believe, looks like a solids day tomorrow going through these comments and process of elimination. Filters and pumps first.
     
  2. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Just as an update I changed the fuel filter and it was an ugly seen, looked like I was planning for gold with all the crap that canoe out, couldn’t source the pump so will need to order one, I don’t have the equipment to check the pressure so was thinking of taking to a bloke in Brisbane in Stafford, he is an air cooled specialist but he may take pity on me and have a look, I’d like a good once over also from a professional to make sure I have no other surprises coming, fingers crossed it is just the pump
     
  3. Barry

    Barry Well-Known Member

    Messages:
    4,666
    Location:
    Abbotsford NSW
    I would be planning on a new tank soon.
     
    UK Skippy likes this.
  4. Grantus

    Grantus Well-Known Member

    Messages:
    16,993
    Location:
    Southern ACT
    Is there just the one filter after the pump?
     
    Last edited: Oct 25, 2019
  5. Luckyphil

    Luckyphil Well-Known Member

    Messages:
    6,566
    Location:
    Gosford
    Unless the pump is noisy leave it alone. If replacing then use the Holden Commodore pump from Repco
     
    Dapom, syncro and UK Skippy like this.
  6. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Yep she’s on the list, seems pretty easy to change and surprising cheap to buy!!
     
  7. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Yes just the 1 filter, I will look to put one on prior to the pump also, probably at the same time of replacing tank.
     
  8. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    No noise from the pump, I was reading this forum and it mentioned noise from the pump which mine doesn’t have. I will hopefully get it in the shop this week and have pressure tested, hopefully this keeps pointing me in the right direction. What model commodore or does it not matter?
     
  9. Luckyphil

    Luckyphil Well-Known Member

    Messages:
    6,566
    Location:
    Gosford
    VI Commodore
     
    UK Skippy likes this.
  10. Barry

    Barry Well-Known Member

    Messages:
    4,666
    Location:
    Abbotsford NSW
    Ummmm....... not true.

    I will dig out my post.
    The problem is the punching that is for the fuel sensor.
    The new ones are flat and the “tabs” are meant to be sawtooth.
    If not done properly they leak.
    If not done properly they rip the O ring to shreds.

    Mine took 6 months to develop the leak.
    Ended up with a custom made cork gasket.

    Why O’ why the new tanks don’t have a flat gasketed flanged bolt on seal I will never know
     
  11. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Bugger
     
    Barry likes this.
  12. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Hi All,
    As an update I had this down to Custom Vee Dub in Brisbane this morning, they were super helpful and whilst don’t do the technical side of water cooled T3s anymore they were happy to have a look and offer mechanical assistance, it has no power under load and they think it could be the Airflow sensor, they suggested Scorpio motors and Andre there has kindly agreed to have a look this Saturday, he has a spare Airflow sensor but not sure how good it is, if I can swap out and identifies the problem I will then be able to order one (I think from US). So at the moment we have moved from Fuel to Air and now I wait until Saturday. If it turns out Andre doesn’t have a sensor I may be asking for anyone in Brisbane to do a swap and test as I believe these sensors are difficult to measure?
     
    Wayne murray and David H like this.
  13. cbus

    cbus Well-Known Member

    Messages:
    12,622
    Location:
    sunshine coast
    Pretty sure I have one to suit that you can compare.
    Expect to be down in bris on weekend if it helps.
     
  14. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    What a Legend CBus, I have Scorpio conforming on Friday he can look at the van for Saturday, if it’s ok with you I’ll come back to you on Friday and possibly bring down. This is what I enjoy about this Forum, people just genuinely trying to help other people, and me with my First VW and limited knowledge this kind of help is worth than money can buy, of course there will be a 6 pack in it for you though
     
    TeeBee likes this.
  15. cbus

    cbus Well-Known Member

    Messages:
    12,622
    Location:
    sunshine coast
    0 280 202 079
    025 906 310C
     
  16. Grantus

    Grantus Well-Known Member

    Messages:
    16,993
    Location:
    Southern ACT
    With the changed filter, there was still no improvement?

    Assuming the fuel pump is still moving enough fuel, then yes, it’s time to move to the amount of air available.

    And if Col, (cbus) can see the vehicle, I’m 100% confident he can point out a few things you may also want to attend to. ;)
     
    oldman likes this.
  17. Barry

    Barry Well-Known Member

    Messages:
    4,666
    Location:
    Abbotsford NSW
    When my tank died I first off replaced the filter
    No changed.
    Replaced pump. No change.

    The amount of crap in there had killed both the new bits straight away.

    Had to change tank, filter and pump to get it right
     
    Last edited: Oct 22, 2019
    David H likes this.
  18. Grantus

    Grantus Well-Known Member

    Messages:
    16,993
    Location:
    Southern ACT
    Been there........twice! :(

    Not twice on the one T3, twice as in both T3’s..;)
     
  19. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Thats the one
     
    cbus likes this.
  20. UK Skippy

    UK Skippy Member

    Messages:
    49
    Location:
    Brisbane
    Hi Col, Scorpio motors are having a look at this for me tomorrow morning and will be able to test everything so at this stage I don’t need your spare for testing, if anything changes I will let you know, thanks again for you offer. Hopefully I will be driving up hills again soon
     

Share This Page