1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Where to mount my electric fuel pump????

Discussion in 'Fuel System & Electrics' started by Rocky, Mar 18, 2011.

  1. Rocky

    Rocky Well-Known Member

    I want to mount my rotary electric pump underneath, but I'm struggling for ideas for a location.

    If any one can show me how they have mounted theirs, it would be a great help.

    Thanks, Chris
     
  2. Alpal

    Alpal Moderator Staff Member

    Messages:
    9,034
    Location:
    Melbourne Bend of Islands
    Mounted the pump and filter on the chassis rail beside the starter motor. Out of site. Below the tank. Out of the engine compartment. Not too close to the exhaust heat. Works tickety-boo!
     
  3. Rocky

    Rocky Well-Known Member

    That's what I was thinking, did you use an existing bolt/hole or drill a new one through????
     
  4. Alpal

    Alpal Moderator Staff Member

    Messages:
    9,034
    Location:
    Melbourne Bend of Islands
    Might have needed to drill. Out of sight out of mind!
     
  5. Rocky

    Rocky Well-Known Member

    haha,
    Not against that at all if it keeps the pump down there out of the way.

    Cheers
     
  6. vassy69SC

    vassy69SC Active Member

    Messages:
    995
    Location:
    Brisbane
    Yeh, that is the area.
    Not a bad idea to use some rubber mounts to take away a little of the noise these things make.
     
  7. geoff62sw

    geoff62sw Member

    Messages:
    768
    Location:
    sydney

    Hi chris

    This is my electric pump(mounted in my Splitty) I fitted it up under the tank area.
    Note that it is rubber mounted.:)
    Hope this helps

    [​IMG]

    [​IMG]
     
  8. jon ward

    jon ward Active Member

    Messages:
    5,752
    Location:
    Travelling Australia
    I had mine rubber mounted to the chassis rail but still got the annoying ticky tick sound so I removed the bolts and zip tied it so it now hangs about 3cm from the chassis rail, no ticky tick!
     
  9. BryceBusDriver

    BryceBusDriver Member

    Messages:
    119
    Location:
    Southern Adelaide
    I have a Facet USA elec pump. Had it rubber mounted by my mechanic in the engine bay but mr 1500King has since moved it to the area near the starter when we did my carbs. Have not heard the any ticking at all in both locations except for the few seconds when it is priming, seems to work great.
     
  10. Rocky

    Rocky Well-Known Member

    Thanks guys, about to dive under and choose a spot near the starter (roughly). Will be rubber mounted for sure, thanks for the input.
    Chris
     
  11. Doc

    Doc Well-Known Member

    Messages:
    2,911
    Location:
    Gunnedah
    But why would you bother Andrew .....I mean with the axle?
     
  12. Rocky

    Rocky Well-Known Member

    Haha, I think we are all waiting for the answer...
     

Share This Page