1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help.

Discussion in 'Performance' started by Bron&Bill, Aug 20, 2012.

  1. Alpal

    Alpal Moderator Staff Member

    Messages:
    8,959
    Location:
    Melbourne Bend of Islands
    Sorry to intrude on the thread but trying to put 1600 twin port back together for Carols 70 Glitter Bug and have not been able to get the gasket/seals for the heat riser tubes mentioned earlier. Any suggestions??
     
  2. grumble

    grumble Well-Known Member

    Messages:
    1,316
    Location:
    Taree
    Alpal I should be able to help give me a call on 0408 025 845 Cheers Les
     
  3. Rossco WA

    Rossco WA Member

    Messages:
    360
    Location:
    Bateman, Perth WA
    Don't forget the engine tin seal as well as all of the above info. It will certainly run better when you've done all this.
     
  4. Bron&Bill

    Bron&Bill New Member

    Messages:
    139
    Location:
    Taree
    So I have or am in the process of fixing all of the pipes and ducting that is missing but what is all the talk of h30/31 etc. I am a 45 yo female, speak in plain English to me please. lol
     
  5. saabman

    saabman Well-Known Member

    Messages:
    4,888
    Location:
    Goulburn
    Hey Bron, the H30/31 refers to the type of carburettor you have acording to 1500kings post you should have a "34 pict 3" type carby.

    Also your distributor is the wrong kind you have a "009" type but you should have a "043905205" type (the number stamped on the side of the distributor)

    the beetle will run with what you have but will run much better with the right parts.

    I hope that helps
     
  6. Bron&Bill

    Bron&Bill New Member

    Messages:
    139
    Location:
    Taree
    Aahh thanks that's better. I get it now.
     

Share This Page